SxUSB.dll

Divers
N'hésitez pas à y poster vos belles images réalisées avec PRiSM bien sûr !
michel_rieutord
Messages : 83
Enregistré le : 27 févr. 2017, 23:18

SxUSB.dll

Message par michel_rieutord »

Bonjour à tous,

Je suis en train d'installer mon nouvel Eagle (l'Eagle5) qui tourne sous
windows 11 et j'ai un probleme de driver avec ma camera SX694. En effet,
Prism 11.4.18.36 (32bit ou 64bit) m'envoie systématiquement le message
"La librairie SxUSB.dll n'a pas pu être chargée/trouvée".

Comme cette librairie est présente dans le répertoire de Prism_V11 je
suppose que le diagnostic est qu'elle n'a pas pu être "chargée". J'avoue
être sec face à ce pb et appelle à l'aide.

J'ai vu que le même pb avait été signalé en 2019 et visiblement
était apparu lors d'un changement de version de windows (win7 à
win10). Je soupçonne qu'il en est de même ici. Sur mon autre Eagle,
qui tourne en windows 10, aucun problème la caméra est bien trouvée.

Je précise que la camera marche et que je peux y accéder avec le soft
StarlightVision. A tout hasard je mets en attaché ce que windows dit à
propos du pilote de la camera.

Je suis preneur de toute idée pour résoudre cette question.

Merci d'avance pour votre aide!

Michel
detail du pilote vu par windows11
detail du pilote vu par windows11
Cyril Cavadore
Messages : 4518
Enregistré le : 18 juin 2009, 22:41
Localisation : 42

Re: SxUSB.dll

Message par Cyril Cavadore »

Bonjour,
je pense qu'il manque des DLL liées au Runtime du visual c++, genre ceci
Lire ici

https://learn.microsoft.com/fr-fr/cpp/w ... w=msvc-170
Cyril Cavadore, ALCOR-SYSTEM, Auteur de PRISM
http://www.alcor-system.com

Pour reporter vos problème, la marche à suivre est ici
viewtopic.php?f=7&t=1403
michel_rieutord
Messages : 83
Enregistré le : 27 févr. 2017, 23:18

Re: SxUSB.dll

Message par michel_rieutord »

Bonjour,

Merci Cyril pour ta réponse. Je suis allé sur
https://learn.microsoft.com/fr-fr/cpp/w ... w=msvc-170
et ai téléchargé+exécuté https://aka.ms/vs/17/release/vc_redist.x64.exe
mais ça n'a rien changé; mais ai-je fait ce à quoi tu pensais?

La camera marche bien et je suis capable de la piloter avec le soft de starlight express
(starlight vision) mais je n'arrive pas à en prendre le controle via prism.
Quelqu'un aurait-il déjà expérimenté le trio windows11+prismV11+camera SX ?

Michel
Eric LE CHEVALLIER
Messages : 157
Enregistré le : 10 août 2018, 11:07

Re: SxUSB.dll

Message par Eric LE CHEVALLIER »

Bonjour ,

Et avec le driver Acom ?

https://www.sxccd.com/support/resources/
michel_rieutord
Messages : 83
Enregistré le : 27 févr. 2017, 23:18

Re: SxUSB.dll

Message par michel_rieutord »

Bonjour,

Oui j'ai essayé avec le driver ASCOM mais sans succès malheureusement.
Il ne trouve pas la caméra (cf capture d'écran attaché). Et il est
vrai qu'avec le gestionnaire de périphérique je ne la vois pas (enfin
je ne sais pas comment elle apparaît avec ce driver), alors qu'avec le
driver natif je la 'vois'.

Vendredi j'ai contacté Terry Platt de SX Ltd qui a pu faire le test
de la combinaison 'windows11+Prism+Camera SX694' et qui n'a pas eu de
problème (c'est rassurant!). J'en déduis que c'est sur mon ordi qu'il
y a qqchose qui coince. Ce qui est curieux est que cela n'affecte que
cette caméra: les autres périphériques (roue à filtre, focuser,
camera zwo...) marchent parfaitement.
capture d'écran du bug avec driver ascom
capture d'écran du bug avec driver ascom
J'ai réinstallé Prism, les drivers de SX et rien n'y fait; mais
bon il y a peut-être une "saleté" qui traîne et qui bloque la
communication. J'ai pensé à réinstaller windows11 mais ça ne garantit
pas la résolution du pb et peut même générer d'autres soucis...
Pour rappel, la caméra marche bien lorsque je la pilote via le soft de
SX, starlight Vision.

Je ne suis pas expert du monde windows, donc là je ne
sais plus trop où chercher. Si vous avez des idées....

Michel

PS une idée comme ça, je n'ai peut-être pas rebooté juste après la désinstallation
de Prism ou du driver. Source de pb ??
michel_rieutord
Messages : 83
Enregistré le : 27 févr. 2017, 23:18

Re: SxUSB.dll

Message par michel_rieutord »

Bonjour,

Finalement j'ai (partiellement) résolu le problème en utilisant le
driver ASCOM. Apparemment celui-ci a aussi besoin du driver natif de
la caméra et si les deux drivers sont installés alors ça marche (ouf!).

Pour moi le mystère reste entier concernant l'accès direct de Prism au driver
natif, qui ne marche pas chez moi mais fonctionne chez SX. Un plus
serait que le message de Prism soit plus explicite pour l'aide au
debugging.

Bon ciel à tous,

Michel
Cyril Cavadore
Messages : 4518
Enregistré le : 18 juin 2009, 22:41
Localisation : 42

Re: SxUSB.dll

Message par Cyril Cavadore »

" le message de Prism soit plus explicite"
J'aimerais bien, mais la c'est windows qui est en cause, l'ouverture d'une DLL se fait avec une fonction loadlibrary d'une DLL de Windows, et ce qui se passe dedans, je n'ai aucune action.
Cyril Cavadore, ALCOR-SYSTEM, Auteur de PRISM
http://www.alcor-system.com

Pour reporter vos problème, la marche à suivre est ici
viewtopic.php?f=7&t=1403
michel_rieutord
Messages : 83
Enregistré le : 27 févr. 2017, 23:18

Re: SxUSB.dll

Message par michel_rieutord »

bonjour Cyril, bonjour à tous,
hier soir j'ai pu tester mon nouveau setup, et donc en particulier
le pilotage de la camera SX694 par le driver ASCOM. Je me suis
aperçu que le défilement du temps durant une pose ne marchait
pas: avec une pose de 60s, le widget affiche 60s puis une fraction
de seconde plus tard 0s. Au final je pense que la pose a bien
duré 60s (je n'ai pas mesuré), mais il est quand même rassurant
de voir le temps de pose défiler, surtout si on veut interrompre
ladite pose à un moment. Est-ce un bug connu? une manip à faire
pour éviter cela?

Je continue les tests...

Michel
michel_rieutord
Messages : 83
Enregistré le : 27 févr. 2017, 23:18

Re: SxUSB.dll

Message par michel_rieutord »

Bonjour Cyril, bonjour à tous,

Je reviens vers vous toujours pour essayer de faire marcher correctement
ma SX694 avec Prism et windows11. Comme dit précédemment j'utilise maintenant le driver ASCOM de cette camera, mais j'ai trois problèmes:
1/ le temps de pose restant ne s'affiche pas
2/ impossible d'arrêter une pose en cours
3/ si la pose est supérieure ou égale à 120s l'image n'est pas sauvegardée :
J'obtiens le message:
"Readimage Error, readoutCompleteLoop -> WaitIReadimage Error, readoutCompleteLoop -> WaitImage_ready loop timeout(120sec)!mage_ready loop timeout(120sec)!"

Remarque : avec la camera guide Lodestar (aussi de SX), tout marche parfaitement.

Dernière question: pour le chargement du driver natif de la SX694, Prism renvoie une erreur mais
on ne sait pas à quelle erreur "windows" elle correspond: la fonction loadlibrary peut planter dans
de multiples cas mais renvoie un numéro d'erreur qu'il serait utile de connaître pour pouvoir utiliser
les données du web à propos de ce bug.

Merci d'avance pour toute aide, piste...

Michel
Cyril Cavadore
Messages : 4518
Enregistré le : 18 juin 2009, 22:41
Localisation : 42

Re: SxUSB.dll

Message par Cyril Cavadore »

Starlight a ecrit ce driver ascom et c'est a eux de l'essayer avec Prism.
L'implementation du driver ASCOM dans prism est vraiment bonne car cela marche avec toutes les cameras du marché, sf celle de cette marque, ou l'aspect logiciel est totalement negligé.... c'est dommage.
Je le demande s'ils vendent encore la moindre camera face a ZWO et QHY.
Cyril Cavadore, ALCOR-SYSTEM, Auteur de PRISM
http://www.alcor-system.com

Pour reporter vos problème, la marche à suivre est ici
viewtopic.php?f=7&t=1403
Répondre